In 2008, you might still need to lie about your OS

Today my sister-in-law, Siobhan, asked me to help her debug her brand new Sky ADSL set-up. She told me her PC, with a wireless adapter, was connecting OK, but she couldn’t get onto the internet at large. I was relieved I had decided to throw my laptop in my bag when I came down to visit as that would make the whole thing a lot easier. I went up to the house, opened my laptop and in a few seconds it was ready from hibernation (into Debian). Very quickly we identified the wireless network, put in the passphrase, and got connected straight away.

So the wireless was working OK as it appeared, and all attempts to surf elsewhere failed. I surfed to 192.168.0.1 and was rewarded by the router login screen, I recognised it as a Netgear device, but the usual netgear “admin” and “password” didn’t cut it. Google, via my N95 supplied that “admin” and “sky” was the answer. Result, I was in and could see that there was an IP allocated to the router. I did some pings from my laptop, and found that the packet loss was almost, but not always, complete, and that sometimes DNS worked, sometimes it didn’t. All my nice tools in Debian made the diagnosis easier. At this point I was assuming a line problem and that the speed would need to be restrained.

So, I hooked the laptop to the router directly with a cable, just to rule anything else out, and because I knew the tech people would fret about it needlessly, and I saw the router kept losing it’s connection periodically – it would stay up for minutes, but nothing useful could be done with it then. So, it was time to ring the dreaded helpline. Siobhan had to go through the usual Q&A, including some quizzing about how her name was spelt, and then I was placed on the phone to speak to the tech-girl as it happened to be in this case. I tried, politely but fairly deperately to short-cut the endless questions by outlining what I had already discovered. She asked me if I was using Vista, I said “No, Linux”, so she asked again if it was Vista or XP, and I said it was neither, it was Linux, but that the problem was between the router and their operation somewhere. So we got put on hold for about 5 minutes, and already I had the feeling of dread – I should have just lied. She came back on the phone and told me that her colleagues said Linux wasn’t supported and I’d have to use another OS so she could talk me through settings.

With now rapidly mounting exasperation I explained I was already connected to the router, both on the network and with a browser, could clearly see the outbound connection going up and down like a yoyo, and that rebooting into another OS would make absolutely no difference to the problem, but of course, she was adamant, so with great irritation and reluctance I rebooted into Vista, waited for it to finally sort itself out, logged in and … the phone line went dead.

So now, punching the floor with irritation, I ask Siobhan to phone back, get through the maze of keypresses and introductions and we get the second person. She wants to start at the beginning, but we try hard to get her to understand what we have already found. She at least seems to understand it’s not an OS problem. She tells me to try another microfilter, I say fine, but I obviously can’t do it just as we’re on the phone, she says “That’s correct, you would be disconnected”. Well… yes, I got that. Anyway, we go through a few other gems and I anticipate her asking me to unscrew the BT master faceplate and plug things in there.

So we do that, with little hope, it doesn’t work. I curse Vista as I try to navigate IE (I don’t even dare use firefox in case they moan about that). Again, we call, the same procedure, the third person, who talks to Siobhan only, and is happy without further technobabble, to finally redirect us to the “Solution Centre” or some such. Siobhan begins to talk to operative number four, and passes me over.

Joy… She understands the problem is at their end, she limits the speed on the connection, just like that it all starts to work. I thank her profusely and say it’s a pleasure to finally get to someone who doesn’t ask me to check if I have an electricity supply. She comes from Northern Ireland too, we share a quick laugh about it all, she helpfully suggests that she’ll leave the ticket open while we check over the weekend the new “fix” is stable. Yes, I know I can be a grumpy old [whatever] about it, and that the tech people often have to speak to people who don’t have a clue what they are doing, but it is exasperating when they can’t go a little beyond the script to realise you might actually know how to help them fix your problem.

Way back in the early days of ISPs in Northern Ireland I found some problem, carefully excluded local causes and called the ISP to report it to them. Foolishly I told them at the time I was using WAN and LAN at the same time (Netware), to which they promptly told me that was impossible and refused to discuss the problem further. I pointed out that not only was it possible, it was all working nicely in the morning. So I called back and just lied that time.

The moral of the story seems to be, when someone asks if you are running Vista, just say “yes”.